Перейти к содержанию
Планета Deus Ex
Авторизация  
nest

реалень ли запуск Project 2027 под win2k?

Рекомендуемые сообщения

написано, что необходим .NET framework версии 3.5 . Но таковой под 2000 не существует.

 

Есть ли какой способ обойти эту проблему?

 

 

Уже попытался проделать описанное тут, но тоже не получилось всё поставить как там сказано.

Изменено пользователем nest

Поделиться сообщением


Ссылка на сообщение

Тут на форуме, вроде, что-то проскальзывало о том, что можно запускать через какой-то .bat-файл, но тогда придется что-то там конфигурировать вручную. Подробнее, к сожалению, рассказать не могу, так как сам в этом не разбираюсь. А вообще, это уродство — создавать людям из ничего проблемы, сам геморился, пока специально для 2027 на WinXP этот долбаный NET ставил :(

Поделиться сообщением


Ссылка на сообщение
А вообще, это уродство — создавать людям из ничего проблемы, сам геморился, пока специально для 2027 на WinXP этот долбаный NET ставил :(

По аккуратнее в выражениях. Ты что за эту игру деньги заплатил? Если ты свою винду не обновлял, то это твои проблемы.

Поделиться сообщением


Ссылка на сообщение

Во времена, когда вышел DeusEx никакого NET в помине не было это раз. И к обновлённой графике NET не имеет никакого отношения, для собственно игры он не нужен, поэтому его наличие не имеет смысла, это просто блажь его создателей — написать лончер непременно на NET, это два. По разным данным около половины юзеров (может немного меньше) до сих пор сидят на WinXP, в котором штатно NET 3.5 тоже нет — это три. Вот всё это в сумме и есть создание проблем из ничего.

Поделиться сообщением


Ссылка на сообщение

DrPeps, всё равно нужно уважать чужой труд. Старались, делали для всех бесплатно.

Разработчики пишут/собирают то, на чём им удобнее. Сам такой :)

 

Пока нашёл вот такой пакет для установки 3.5 на win2k:

http://www.msfn.org/board/topic/142222-net-framework-35-sp1-project/

но тоже с плясками с бубном... ставлю сейчас. отпишусь.

 

... требует .NET Framework 2.0 Service Pack 2 , а он отказывается ставиться с неизвестной ошибкой...

Изменено пользователем nest

Поделиться сообщением


Ссылка на сообщение

По разным данным около половины юзеров (может немного меньше) до сих пор сидят на WinXP, в котором штатно NET 3.5 тоже нет — это три.

Юзеры могут сидеть хоть на Досе. А в WinXP NET 3.5 есть.

 

post-7548-036639900 1311660053.gif

Поделиться сообщением


Ссылка на сообщение
Во времена, когда вышел DeusEx никакого NET в помине

Круто, жаль, что сейчас не те времена.

Как играть в современные игры, не ставя NET Framework?

 

Ответ: никак.

 

 

8dVKr.png

 

 

Решил поиграть во что-то современное -- вот и ставь. Закрыли тему нытья.

Поделиться сообщением


Ссылка на сообщение

Тут на форуме, вроде, что-то проскальзывало о том, что можно запускать через какой-то .bat-файл, но тогда придется что-то там конфигурировать вручную. Подробнее, к сожалению, рассказать не могу, так как сам в этом не разбираюсь. А вообще, это уродство — создавать людям из ничего проблемы, сам геморился, пока специально для 2027 на WinXP этот долбаный NET ставил :(

.NET установленный на компьютере это так же естественно и необходимо как чистить зубы и вытирать задницу. Подавляющее большинство игр и большое число приложений используют .NET, так что "специально для 2027" звучало довольно забавно.

 

реалень

1258200983555.gif

Поделиться сообщением


Ссылка на сообщение

Никак не соглашусь, что .Net прямо так уж и необходим. Да, это сейчас модно, но он совершенно не необходим. Его применение можно считать оправданным там, где действительно есть реальная польза от его библиотеки готовых объектов, но для простого приложения, которое что-то пишет в конфиг и потом запускает экзешник, преимуществ дотнета по сравнению с нативными языками нет. И ладно бы сама игра работала через .Net, но речь идёт об игре, которая прекрасно работает на Windows 2000 (да что там, на Windows 9x) безо всякого .Net вообще (его и в проекте не было, когда писали игру).

 

 

И игра вполне себе нормально запускается следующим батником, лежащим в корневой папке деуса:

@echo off
cd System
start "" 2027.exe ini="..\2027\System\2027.ini" userini="..\2027\System\2027User.ini" log="..\2027\System\2027.log"
cls

Единственное что разрешение экрана придется вручную прописать в файле 2027\System\2027.ini, один раз, в секции [WinDrv.WindowsClient].

Поделиться сообщением


Ссылка на сообщение

Сколько уже можно ныть? .NET 3.5 есть у всех, кто за последние четыре года включал Windows update. Альтернативные клиенты пишите сами, я не собираюсь тратить свое время на тех, кому лень скачать полсотни мегабайт (зато не лень пиздеть об этом по форумам).

Windows 2000 официально не поддерживается Майкрософтом уже больше года, обсуждать здесь нечего.

Поделиться сообщением


Ссылка на сообщение
Гость
Эта тема закрыта для публикации ответов.
Авторизация  
×
×
  • Создать...